Scanning Markets

Last modified 10:36, 5 Nov 2012

Running a Scan

In order to run a scan, the scan must be open.

Scans can be opened by selecting and existing, saved scan or by creating a new scan.

Open Existing Market Scan

The Scanners button on the Tool Bar contains links to all the important scanning interfaces:

tolbutn_scanpsopenms.png

In addition to the Tool Bar’s Scanners menu, saved Market Scans can be accessed from an number of different locations including the Open commands of the File menu, and from System Testing.

The Open Market Scanner command will open the Select a file... dialog box from which to choose a scan to run. The dialog will display preconfigured scans, see next section, as well as any user defined Market Scans that were previously saved.

All Market Scan files have the .mks file extension.

Preconfigured Scans

Your SOFTWARE includes a number of scans that have preconfigured settings. They are included with the software and are placed in the saved scan list at installation.

The following preconfigured scans are included with Your SOFTWARE:

  • Wave 5 Sell.mks
  • Wave 5 Buy.mks
  • Wave 4 Sell.mks
  • Wave 4 Buy.mks
  • Trend Finder.mks
  • End Counter Trend - Short.mks
  • End Counter Trend - Long.mks

These preconfigured scans are normal, off-line .mks files and can be run exactly like other user-defined market scans except that any user defined changes, while applicable to the scan to be run, cannot be saved. If users want to save the altered criteria, use the Save Scanner As... command in the Action menu.

Note - The on-line equivalent of preconfigured off-line scans are the Pre-computed scans (see the next topic for more information). Users of Pre-computed scans have the additional advantage of not having to wait for the results to be generated. This is done automatically on the server as soon as all the required data is available. The results are then saved on the server for access by users at any time.

Create a New Market Scan

You can also create a new market scan.

Select the New Market Scan command from the New submenu of the File menu:

menubtn_filenewps_ms.gif

The Market Scan work page will open with the Search Criteria tabbed page open.

Select a Criteria type and Add it to the Scan Criteria list.

Make the appropriate setting to the scan criteria and scope and Save the scan.

For more information, go to the Search Criteria help topic.

System Testing Interface

Scans can also be run and edited from an number of different areas in the System Testing interface.

Pre-Scan Adjustments

Once a scan is open, regardless of whether it is a new scan, a preconfigured scan, or a previously saved scan, the details for the selected scan, including its current criteria expressions, will be displayed.

At this point users can do either of the following:

  • Run the scan as it is
  • Select a different market (the only choice for on-line scans), or different group such as market or pre-computed scan results or quote pages
  • Choose to scan on weekly intervals (off-line only)
  • Select a different data date, or
  • Edit/delete any of the criteria expressions or add new criteria expressions

You can directly edit the market selection text boxes, and you can edit existing scan criteria, add new criteria or delete existing criteria from the scan criteria expressions list on the right.

Scanning Process

The process of running a scan will vary depending on whether the scan is an Off-line scan or an On-line scan.

Off-line Market Scan

Off-line scans are performed on data already downloaded onto your local PC.

To provide you with the most current scan results, an off-line scan requires the data on your computer to be up–to–date.

To remind you of this data maintenance issue, the following warning appears each time you start an off-line scan:

offlinwarning.gif

Update your price data using the Update Manager from the Tools menu.

The time taken to complete the update will depend on the markets selected and your data connection.

If you regularly update your data, and do not want to see this warning message, select Don't ask me this again to turn off this warning function.

Start Scan

If you are satisfied that your local data is sufficiently up to date, click the Start button to begin the scan:

butn_scanstartooltip.gif                butn_scanstoptooltip.gif

At any time during the scan you can press the Stop button to end the scan.

Off-line Scan Progress

Depending on the number of securities in the market or group selected to Search On, the scan may take some time.

The Search Results Progress bar will inform you of the scan’s progress:

mrktscan_runscanprogress.gif

The Scanning indicator will wipe backwards and forwards while the scan is running and the progress of the scan is shown as a percentage of the total Search Group Searched.

Results

When the scan is complete, 100% will be shown as searched and the final figures for symbols which matched the criteria will be displayed in three categories: the scan Meets All, Meets Some or Meets None of the criteria.

The number of results shown, depends on the settings of the display Filters.

For more information on interpreting and using the scan results, go to the Market Scan Results help topic.

On-line Market Scan

On-line scans send queries to the server, where the actual scan of price data is performed.

Start Scan

If you are satisfied that your local data is sufficiently up to date, click the Start button to begin the scan:

butn_scanstartooltip.gif                butn_scanstoptooltip.gif

At any time during the scan you can press the Stop button to end the scan.

On-line Scan Progress

An on-line scan will connect to the data server, the Remote Data Monitor and the Remote Action Panel will display details of the data download:

remoteactmontron.gif

Detach the Remote Action Window for more details on the download process:

mrktscan_runolscandatawin.gif

The actual time taken to complete a market scan will depend on the size of the market selected to be scanned, the complexity of the criteria expressions contained in the scan, and your data connection.

While the scan is taking place, the scan progress indicator will appear in the function bar:

scanindictr.gif

The results of the scan will appear in the market scan results table, see Scan Results, below.

Results

When the scan is complete, the results will be displayed in the same way as for Off-Line scans, see above.

For more information on interpreting and using the scan results, go to the Market Scan Results help topic.

Page statistics
762 view(s) and 5 edit(s)
Social share
Share this page?

Tags

This page has no classifications.

Comments

You must to post a comment.

Attachments